Soucis avec fonction de pièce, assistant et procédé

Conception pièces mécaniques, machines spéciales, composants...

Modérateurs : remi77, D@vid

Nico64
Caporal-chef
Caporal-chef
Messages : 40
Inscription : 01 oct. 2019, 14:31
Version TopSolid : 7.13
Module TopSolid : TopSolid'Design
Localisation : Aire sur l'Adour

Soucis avec fonction de pièce, assistant et procédé

Message non lu par Nico64 » 25 mars 2020, 08:40

Bonjour à tous.

Dans notre secteur d'activité (metallerie / serrurerie), nous sommes amenés à souvent utiliser les produits de la marque Locinox. Je me suis fait envoyé tous les step dont j'avais besoin. J'ai entrepris de créer tous les procédés de perçages et ouvertures liés à ces produits.

Au niveau des serrures, aucun soucis.

1-J'ai tout d'abord créer une fonction pièce regroupant 3 plans de positionnement.
2-Ensuite, j'ai attribué cette fonction aux différentes serrures.
3-Ensuite, j'ai créer l'assistant de positionnement reprenant la fonction.
4-Pour finir, j'ai créer le procédé avec les trous de passage pour le penne et les vis de fixations.

Tout marche nickel, c'est du bonheur.

Mais c'est au niveau des gâches que cela coince.
J'ai effectué strictement la même procédure.

Mais lorsque j'insère la gâche, TopSolid me fait remonter cette erreur :
2020-03-24.png
La référence "LSKZ U2 STEP" concerne la serrure... Les deux n'ont pourtant aucun lien... Et proviennent de la même bibliothèque qui est référencée dans mon projet...
Du coup le procédé ne se charge pas. J'ai seulement ma gâche de positionner.

Si quelqu'un a une idée du pourquoi du comment ?

En vous remerciant.

@+
Vous ne pouvez pas consulter les pièces jointes insérées à ce message.
Dernière modification par Nico64 le 27 mars 2020, 07:57, modifié 1 fois.

Avatar de l’utilisateur
JuP
Général de brigade
Général de brigade
Messages : 3934
Inscription : 18 févr. 2013, 10:26
Version TopSolid : 7.14
Module TopSolid : TopSolid'Design
Localisation : Lyon (France)

Re: Soucis avec fonction de pièce, assistant et procédé

Message non lu par JuP » 25 mars 2020, 09:24

Bonjour Nico64,
1-J'ai tout d'abord créer une fonction pièce regroupant 3 plans de positionnement.
2-Ensuite, j'ai attribué cette fonction aux différentes serrures.
3-Ensuite, j'ai créer l'assistant de positionnement reprenant la fonction.
4-Pour finir, j'ai créer le procédé avec les trous de passage pour le penne et les vis de fixations.

Tout marche nickel, c'est du bonheur.
Bravo, c'est super !
La référence "LSKZ U2 STEP" concerne la serrure... Les deux n'ont pourtant aucun lien... Et proviennent de la même bibliothèque qui est référencée dans mon projet...
Du coup le procédé ne se charge pas. J'ai seulement ma gâche de positionner.

Si quelqu'un a une idée du pourquoi du comment ?
Je pense que lors du procédé, TopSolid essaie de faire une synchro entre ta gache et ta serrure en volant opérer cette dernière.

Il faudrait contrôler plusieurs choses:
- Lancer la commande PDM Référence sur ta famille Serrure: le but c'est de vérifier que tous les morceaux de ta serrure sont bien dans ta bibliothèque et qu'un morceau ne traîne pas quelque part

- Vérifier le procédé de ta gache: la gache ne devrait pas détecter la serrure et tenter de la percer, la méthode de détection pour effectuer le procédé doit pouvoir être améliorée (je pense)

Pour contourner le problème:
- Désactive le procédé automatique
2020-03-25_09-21-00.png
- Quand tu fais ton procédé, passe en sélection manuelle et sélectionne les pièces que tu veux opérer:
2020-03-25_09-23-14.png
Ton procédé devrait se faire sans problème avec ça.
Vous ne pouvez pas consulter les pièces jointes insérées à ce message.
Julien POIROT
Responsable produit TopSolid'Steel
Youtube
GrabCad

Nico64
Caporal-chef
Caporal-chef
Messages : 40
Inscription : 01 oct. 2019, 14:31
Version TopSolid : 7.13
Module TopSolid : TopSolid'Design
Localisation : Aire sur l'Adour

Re: Soucis avec fonction de pièce, assistant et procédé

Message non lu par Nico64 » 25 mars 2020, 09:42

Bonjour Julien.

Effectivement, en désactivant les procédés auto cela marche.

Je n'ai pas de famille de serrure. Je navigue dans l'arborescence que j'ai organisé en dossier par type d'utilisation.

Toutes les pièces de la gâche et serrure sont bien présentes dans la bibliothèque. Elles n'ont aucun lien entre elle... Surement un soucis au niveau de mon procédé...

Nico64
Caporal-chef
Caporal-chef
Messages : 40
Inscription : 01 oct. 2019, 14:31
Version TopSolid : 7.13
Module TopSolid : TopSolid'Design
Localisation : Aire sur l'Adour

Re: Soucis avec fonction de pièce, assistant et procédé

Message non lu par Nico64 » 27 mars 2020, 07:56

Bonjour Julien.

Alors, j'ai résolu mon soucis avec l'aide de mon formateur.

L'erreur venait du fait que la poche que je créer avec le procédé de la gâche n'était pas assez profond, et du coup le penne papillon de la serrure venait interférer avec cette opération.

En manuel, cela fonctionnait nickel car je ne sélectionnais que le poteau de réception de la gâche, là où le mode automatique prends en compte l'ensemble des pièces périphériques.

On en apprends tout les jours ^^

Répondre